Back to overview
Degraded
Jupiter Source Unstable
Mar 16, 2026 at 1:25am UTC
Affected services
Jupiter
Resolved
Mar 17, 2026 at 12:11am UTC
The issue has been resolved. The Jupiter source is now stable, and users should no longer experience buffering or stuttering during playback
Affected services
Created
Mar 16, 2026 at 1:25am UTC
The source Jupiter is slow on load times and may stop randomly during a show or movie. Again, this is not fixable by Cinerealm and can only be fixed by the source itself. Stability with Jupiter is not guaranteed at this time.
Affected services