Back to overview
Downtime
Jupiter Source Down
Mar 11 at 10:10am PDT
Affected services
Jupiter
Resolved
Mar 11 at 11:15am PDT
Jupiter functionality came back. Jupiter source was once again operational and loading the movies/shows quickly.
Affected services
Created
Mar 11 at 10:10am PDT
On 03/11/2026 The "Jupiter" source went down and was no longer loading. Upon review and testing, it is not controllable by Cinerealm, and had nothing to do with Cinerealms code. The source Jupiter gave out errors after really long loading times and we must wait for the API/source to be functional again.
Affected services